Stickers: making a random shape one

From LDraw.org Wiki
Jump to: navigation, search

This tutorial describes how to use LD Part Editor to make a random shape sticker from a pattern drawn with LD Pattern Creator.

  • Create the pattern with LD Pattern Creator
Stick01.JPG

  • Export the LDraw file from top: File -> Export as .DAT -> Project on XZ plane (top)
Stick02.JPG

  • Open that file in LDraw part editor
  • We now need to move the pattern to y=-0.25 ldu and create back side of sticker at y=0.
  • Select everything (Ctrl+A), then Action -> Set X/Y/Z
  • Set Y=-0.25 then hit "Create Copy" Button
Stick03.JPG

Looking closely, we see that the pattern was properly duplicated:

Stick04.JPG

  • But if we lookd at back side, we see that the surfaces have a wrong winding and appear all red in LDPE (to enable this view mode: right click in view window, then View Actions -> Red Backfaces)
Stick05.JPG

  • In order to correct this: select one face of back side, hit alt+C (or Select ... Connected) to select complete back face, then invert winding (hit J or toolbar icon as shown)
Stick06.JPG

  • We now need to remove pattern from back side, in order to simplify it and minimize number of faces. Basically we need to select all pattern vertices (but not outer edge) and collapse them to a single vertex (or several for complex shapes with concave areas). This can be done by selecting vertices with marquee selection, but here the pattern is completely surrounded by a black border so we'll use that: select one surface in each black region, then Select -> ...with same color (alt+S) / Select ...connected (alt+C). We collapse vertices to a single one with Action -> Merge to Average (Ctrl+W)
Stick07.JPG
Stick08.JPG
Stick09.JPG

  • The final steps will create the edge of sticker. Select top surface by selecting a face, then Select -> ...Connected (Alt+C) - don't forget to uncheck ...with same color option. Then Tools -> Edger2 with scope set to selection. This operation creates a red edge line around top surface.
Stick10.JPG

  • Select one line of that border, and extend it to the whole border edge (Select -> ...with Same Type then Select -> ...Connected), condline threshold angle = 90° (to avoid creation of edge lines)
Stick11.JPG

  • Now we create the edge of sticker, by extrusion of this line: Tools -> Ytruder. Work on Y direction, Translation by distance = 0.25,
Stick12.JPG

  • The newly created edge may have a wrong winding. If it appears red (see above), hit "J" to invert it (it remains selected ater Ytruder operation)
Stick13.JPG

  • Select again the red border line and hit "Del" to delete it - Your sticker is done!
Stick14.JPG